Control Panel/Webmail Change Delays
Incident Report for System Status
Resolved
This incident has been resolved.
Posted May 26, 2022 - 12:23 EDT
Investigating
Control Panel/Webmail Change Delays

We are aware of an issue within our Control Panel and Webmail interface that is resulting in delays when accessing or making changes. This includes but is not limited to the following:

Password Changes
Modifying Mailboxes and Administrators
Mailbox Creation
Mailbox Forwarding
Settings Automatic Replies

Our Engineers are engaged and investigating this issue. In the meantime, we recommend that administrators avoid making any changes until further notice.
Posted May 26, 2022 - 08:56 EDT
This incident affected: Webmail.